Stop Using Internet Explorer Until It's Patched, Warn U.S. & U.K. Governments

Internet Explorer If you are reading this in Internet Explorer, you should probably close it and fire up Chrome – and come back after a newly reported zero-day flaw is patched. Even the U.S. and U.K. governments are warning against use of Internet Explorer for now. The zero-day flaw has been uncovered in Internet Explorer versions 6,7, 8, 9, 10, and 11, according to Microsoft. Those browser versions comprise around 50 percent of the global browser market, the BBC notes. Microsoft proposes a number of mitigatory measures that can be taken, but for now I’d just sit out the Internet Explorer game. Microsoft has made large strides with Internet Explorer in the past few years, so to see the company admit to a stinging security flaw even in the latest Internet Explorer 11 that ships with the current Windows 8.1 is somewhat disappointing.

Read the full story at TechCrunch.